使用 python-future 兼容 Python 2 和 3

粗略看了一下这个库,感觉挺方便的,可以写 Python 3 的代码并运行在 Python 2 上,这样就可以大胆用 Python 3 的功能了。而且 six 那种兼容方法也支持,只是兼容的版本只包括 Python 2.6+ 和 3.3+,如果不需要那么广泛的兼容,future 应该可以替代 six 了。就是太复杂。。。

跟 six 的对比在这里:http://python-future.org/faq.html#what-is-the-relationship-between-future-and-six

0 comments